Back to overview
Degraded

Delayed E-mail Delivery

Apr 09 at 09:13am CEST

Resolved
Apr 09 at 04:11pm CEST

All e-mail deliveries are now back to normal. We apologise for any inconvenience.

Created
Apr 09 at 09:13am CEST

Some users are currently experiencing delays in e-mail notifications being delivered. We are actively working on improving the speed of e-mail delivery from our platform.